Back to overview
Degraded
New York Unavailable
May 27, 2026 at 4:00pm UTC
Affected services
New York
Resolved
May 29, 2026 at 6:36pm UTC
This has now been resolved and NYC is back into the active pool.
Affected services
Updated
May 28, 2026 at 4:22pm UTC
This is still on-going as there appears to be a routing issue with their backup transit provider. We are waiting on them to reactivate GSL and will turn on our NYC region.
Affected services
Created
May 27, 2026 at 4:00pm UTC
One of our upstream carriers has a fibre cut which is degrading performance in our New York region, we have re-routed around New York until the network stabilizes.
There should be no impact to email during this time.
Affected services