Back to overview
Degraded

New York Unavailable

Feb 27 at 09:20pm UTC
Affected services
New York

Resolved
Feb 27 at 10:10pm UTC

The cloud provider has recovered and New York is back online. No mail was lost during this degraded period.

Created
Feb 27 at 09:20pm UTC

Our cloud provider is having an outage in New York. We have re-routed around New York until they resolve the issue.