Back to overview
Maintenance

Server Migration

Dec 14, 2025 at 12:00am UTC  –  Dec 14, 2025 at 12:28am UTC
Affected services
SMTP Inbound
SMTP Outbound
Transactional Email

Resolved
Dec 14, 2025 at 12:28am UTC

Maintenance is now completed. If you experience any issues please contact our support team.

Thanks again for your patience during this maintenance period.

Updated
Dec 14, 2025 at 12:04am UTC

The cut over is complete and mail is flowing. We are running tests to confirm the migration is complete.

Updated
Dec 14, 2025 at 12:01am UTC

This is now underway.

Created
Dec 14, 2025 at 12:00am UTC

We’ll be performing scheduled maintenance as we migrate to a new cloud provider. Expected downtime is just a few minutes during BGP convergence. No major impact expected.