Back to overview
Resolved
Microsoft Delivery Issues
Sep 4, 2026 at 10:35am UTC
Affected services
SMTP Outbound
Resolved
Sep 4, 2026 at 12:52pm UTC
We've seen a significant improvement in delivery rates and confident this is now resolved. Any deferred emails should resend again shortly.
Affected services
Updated
Sep 4, 2026 at 11:42am UTC
Microsoft have declared an active incident (EX1467029).
Affected services
Created
Sep 4, 2026 at 10:35am UTC
Microsoft is experiencing delivery issues, we're only seeing this in the New York region currently.
Customers may experience elevated 451 4.7.500 Server busy. Please try again later from {IP_ADDRESS} errors.
We will continue to monitor and have opened a case with Microsoft.
Affected services