Back to overview
Resolved

New York Deliverability Issues

Aug 21, 2026 at 10:32pm UTC
Affected services
SMTP Outbound

Resolved
Aug 21, 2026 at 10:32pm UTC

Between 7:32 PM UTC and 10:43PM UTC we experienced a silent failure in some of our infrastructure in New York. Our teams have corrected the issue, however we are implementing changes immediately to improve the processes that lead to an error that was not present in our existing monitoring stack.